Skip to main content
← All vulnerabilities
CVE-2021-21334GHSA-6G2Q-W5J3-FWH4

environment variable leak

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.3.10, 1.4.4
None on Exploit-DB, Metasploit or GitHub

Summary

In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • containerd containerd

    fixed in 1.3.10; From 1.4.0 · fixed in 1.4.4

  • github.com/containerd/containerdGo

    From 1.4.0 · fixed in 1.4.4

  • github.com/containerd/containerdGo

    fixed in 1.3.10

References 8

GitHub · containerd/containerd

lists.fedoraproject.org

security.gentoo.org