Skip to main content
← All vulnerabilities
CVE-2021-21032GHSA-4JFQ-F8HC-775QBIT-MAGENTO-2021-21032

Magento Commerce Failure To Invalidate User Session Could Lead To Unauthorized Access

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.1-p1, 2.3.6
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) do not adequately invalidate user sessions. Successful exploitation of this issue could lead to unauthorized access to restricted resources. Access to the admin console is not required for successful exploitation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.1; through 2.4.0-p1; through 2.3.6

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.1-p1

  • magento/community-editionPackagist

    fixed in 2.3.6

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com