Skip to main content
← All vulnerabilities
CVE-2021-21030GHSA-6988-G89M-27VFBIT-MAGENTO-2021-21030

Magento Commerce Stored Cross-site Scripting Could Lead To Arbitrary Javascript Execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.6, 2.4.1-p1
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to a stored cross-site scripting (XSS) in the customer address upload feature. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Exploitation of this issue requires user interaction.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.1; through 2.4.0-p1; through 2.3.6

  • magento/community-editionPackagist

    fixed in 2.3.6

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.1-p1

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com