Skip to main content
← All vulnerabilities
CVE-2021-21029GHSA-JWXH-WJ79-CCM6BIT-MAGENTO-2021-21029

Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.6-p1, 2.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Adobe Magento Commerce

    through 2.4.1; through 2.4.0-p1; through 2.3.6

  • magento/community-editionPackagist

    fixed in 2.3.6-p1

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.2

References 1

helpx.adobe.com