CVE-2021-21025GHSA-H437-QJJ9-VMQ4BIT-MAGENTO-2021-21025
Magento Commerce XML Injection Could Lead To Arbitrary Code Execution
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.6-p1, 2.4.1-p1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to XML injection in the product layout updates. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.1; through 2.4.0-p1; through 2.3.6
- magento/community-editionPackagist
fixed in 2.3.6-p1
- magento/community-editionPackagist
From 2.4.0 · fixed in 2.4.1-p1
- magento/project-community-editionPackagist
through 2.0.2