CVE-2021-21024GHSA-RJ4F-CP4V-HVCVBIT-MAGENTO-2021-21024
Magento Commerce Blind SQL Injection Could Lead To Unauthorized Access
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.6-p1, 2.4.1-p1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a blind SQL injection vulnerability in the Search module. Successful exploitation could lead to unauthorized access to restricted resources by an unauthenticated attacker. Access to the admin console is required for successful exploitation.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.1; through 2.4.0-p1; through 2.3.6
- magento/community-editionPackagist
fixed in 2.3.6-p1
- magento/community-editionPackagist
From 2.4.0 · fixed in 2.4.1-p1