Skip to main content
← All vulnerabilities
CVE-2021-21019GHSA-MW95-GMW4-883PBIT-MAGENTO-2021-21019

Magento Commerce XML Injection Could Lead To Remote Code Execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.6-p1, 2.4.1-p1
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to XML injection in the Widgets module. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.1; through 2.4.0-p1; through 2.3.6

  • magento/community-editionPackagist

    fixed in 2.3.6-p1

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.1-p1

References 1

helpx.adobe.com