Skip to main content
← All vulnerabilities
CVE-2021-21018GHSA-RV48-V862-MP92BIT-MAGENTO-2021-21018

Magnto Commerce Unauthorized Data Modification Could Lead To Arbitrary Code Execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.6, 2.4.1-p1
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to OS command injection via the scheduled operation module. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.1; through 2.4.0-p1; through 2.3.6

  • magento/community-editionPackagist

    fixed in 2.3.6

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.1-p1

References 1

helpx.adobe.com