Skip to main content
← All vulnerabilities
CVE-2021-20750GHSA-VRPV-26FM-7VF7

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.6
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • EC-CUBE CO.,LTD. EC-CUBE

    Version range not reported

  • ec-cube/ec-cubePackagist

    From 3.0.0 · through 3.0.18-p2

  • ec-cube/ec-cubePackagist

    From 4.0.0 · fixed in 4.0.6

References 3

ec-cube.net

jvn.jp