Skip to main content
← All vulnerabilities
CVE-2021-20280GHSA-X2JP-HH65-4XVFBIT-MOODLE-2021-20280

Text-based feedback answers required additional sanitizing to prevent stored XSS and blind SSRF risks in moodle before 3.10.2, 3.9.5, 3.8.8,

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17
None on Exploit-DB, Metasploit or GitHub

Summary

Text-based feedback answers required additional sanitizing to prevent stored XSS and blind SSRF risks in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a moodle

    Version range not reported

  • moodle/moodlePackagist

    From 3.10 · fixed in 3.10.2

  • moodle/moodlePackagist

    From 3.9 · fixed in 3.9.5

  • moodle/moodlePackagist

    From 3.8 · fixed in 3.8.8

  • moodle/moodlePackagist

    From 3.5 · fixed in 3.5.17

References 6

bugzilla.redhat.com

moodle.org

lists.fedoraproject.org

packetstormsecurity.com