CVE-2021-20191GHSA-8F4M-HCCC-8QPHPYSEC-2021-124
A flaw was found in ansible.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.9.18rc1, 2.8.19rc1, 2.10.7, 2.8.19, 2.9.18
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in ansible. Credentials, such as secrets, are being disclosed in console log by default and not protected by no_log feature when using those modules. An attacker can take advantage of this information to steal those credentials. The highest threat from this vulnerability is to data confidentiality. Versions before ansible 2.9.18 are affected.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a ansible
ansible 2.9.18
- ansiblePyPI
From 2.9.0a1 · fixed in 2.9.18rc1
- ansiblePyPI
fixed in 2.8.19rc1
- ansiblePyPI
From 2.10.0a1 · fixed in 2.10.7
- ansiblePyPI
fixed in 2.8.19; From 2.9.0 · fixed in 2.9.18; From 2.10.0 · fixed in 2.10.7