CVE-2021-20187GHSA-2JRM-GWW7-WCH2BIT-MOODLE-2021-20187
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.5.16, 3.8.7, 3.9.4, 3.10.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a moodle
Version range not reported
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.16
- moodle/moodlePackagist
From 3.8 · fixed in 3.8.7
- moodle/moodlePackagist
From 3.9 · fixed in 3.9.4
- moodle/moodlePackagist
From 3.10 · fixed in 3.10.1