CVE-2021-20184GHSA-MM73-86F9-5X5CBIT-MOODLE-2021-20184
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.8.7, 3.9.4, 3.10.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a moodle
Version range not reported
- moodle/moodlePackagist
From 3.8 · fixed in 3.8.7
- moodle/moodlePackagist
From 3.9 · fixed in 3.9.4
- moodle/moodlePackagist
From 3.10 · fixed in 3.10.1