Skip to main content
← All vulnerabilities
CVE-2020-8623

A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.11.22, 9.16.6, 9.17.4, 9.11.22-S1
None on Exploit-DB, Metasploit or GitHub

Summary

In BIND 9.10.0 -> 9.11.21, 9.12.0 -> 9.16.5, 9.17.0 -> 9.17.3, also affects 9.10.5-S1 -> 9.11.21-S1 of the BIND 9 Supported Preview Edition, An attacker that can reach a vulnerable system with a specially crafted query packet can trigger a crash. To be vulnerable, the system must: * be running BIND that was built with "--enable-native-pkcs11" * be signing one or more zones with an RSA key * be able to receive queries from a possible attacker

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • ISC BIND9

    From 9.10.0; fixed in 9.11.22; From 9.12.0; fixed in 9.16.6; From 9.17.0; fixed in 9.17.4; From 9.10.5-S1 · fixed in 9.11.22-S1

References 11

kb.isc.org

lists.fedoraproject.org

security.netapp.com

usn.ubuntu.com

debian.org

lists.debian.org

security.gentoo.org

synology.com

lists.opensuse.org