CVE-2020-8559GO-2024-2748GHSA-33C5-9FX5-FVJM
Privilege escalation from compromised node to cluster
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.16.13, 0.17.9, 0.18.7-rc.0, 1.16.13, 1.17.9, and 2 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 proofs of concept on GitHub
Summary
The Kubernetes kube-apiserver in versions v1.6-v1.15, and versions prior to v1.16.13, v1.17.9 and v1.18.6 are vulnerable to an unvalidated redirect on proxied upgrade requests that could allow an attacker to escalate privileges from a node compromise to a full cluster compromise.
Timeline
- CVE published
- Record last updated
Affected versions
- Kubernetes Kubernetes
From 1.16 · through 1.16.12; From 1.17 · through 1.17.8; From 1.18 · through 1.18.5
- k8s.io/apimachineryGo
fixed in 0.16.13; From 0.17.0 · fixed in 0.17.9; From 0.18.0 · fixed in 0.18.7-rc.0
- k8s.io/kubernetesGo
fixed in 1.16.13; From 1.17.0 · fixed in 1.17.9; From 1.18.0 · fixed in 1.18.7
- k8s.io/apimachineryGo
fixed in 0.16.13
- k8s.io/apimachineryGo
From 0.17.0 · fixed in 0.17.9
- k8s.io/apimachineryGo
From 0.18.0 · fixed in 0.18.7
- k8s.io/kubernetesGo
fixed in 1.16.13
- k8s.io/kubernetesGo
From 1.17.0 · fixed in 1.17.9
- k8s.io/kubernetesGo
From 1.18.0 · fixed in 1.18.7