CVE-2020-8552GHSA-82HX-W2R5-C2WQ
Kubernetes API server denial of service
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in v1.17.3, v1.16.7, v1.15.10, 0.15.10, 0.16.7, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Kubernetes API server component in versions prior to 1.15.9, 1.16.0-1.16.6, and 1.17.0-1.17.2 has been found to be vulnerable to a denial of service attack via successful API requests.
Timeline
- CVE published
- Record last updated
Affected versions
- Kubernetes Kubernetes
fixed in v1.17.3; fixed in v1.16.7; fixed in v1.15.10
- k8s.io/apiserverGo
fixed in 0.15.10
- k8s.io/apiserverGo
From 0.16.0 · fixed in 0.16.7
- k8s.io/apiserverGo
From 0.17.0 · fixed in 0.17.3