Skip to main content
← All vulnerabilities
CVE-2020-8244GHSA-PP7H-53GX-MX7R

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even ty

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.2.3, 2.2.1, 3.0.1, 4.0.3
None on Exploit-DB, Metasploit or GitHub

Summary

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a bl

    Version range not reported

  • blnpm

    fixed in 1.2.3

  • blnpm

    From 2.0.0 · fixed in 2.2.1

  • blnpm

    From 3.0.0 · fixed in 3.0.1

  • blnpm

    From 4.0.0 · fixed in 4.0.3

References 2

hackerone.com

lists.debian.org