Skip to main content
← All vulnerabilities
CVE-2020-7919GHSA-CJJC-XP8V-855WBIT-GOLANG-2020-7919GO-2022-0229

Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attack

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.16.8, 3.1.0, 0.0.0-20200124225646-8b5121be2f68, 1.12.16, 1.13.7
None on Exploit-DB, Metasploit or GitHub

Summary

Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients (resulting in a panic) via a malformed X.509 certificate.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/helm/helmGo

    From 2.0.0 · fixed in 2.16.8

  • helm.sh/helm/v3Go

    From 3.0.0 · fixed in 3.1.0

  • golang.org/x/cryptoGo

    fixed in 0.0.0-20200124225646-8b5121be2f68

  • stdlibGo

    fixed in 1.12.16; From 1.13.0-0 · fixed in 1.13.7

References 7

lists.fedoraproject.org

groups.google.com

debian.org

oracle.com

security.netapp.com