CVE-2020-7009GHSA-GFV5-GRX2-9JW2BIT-ELASTICSEARCH-2020-7009
Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create A
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.8.8, 7.6.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
Timeline
- CVE published
- Record last updated
Affected versions
- Elastic Elasticsearch
Version range not reported
- org.elasticsearch:elasticsearchMaven
From 6.7.0 · fixed in 6.8.8
- org.elasticsearch:elasticsearchMaven
From 7.0.0 · fixed in 7.6.2