Skip to main content
← All vulnerabilities
CVE-2020-5263GHSA-PRFQ-F66G-43MP

Information disclosure through error object

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.12.3, 9.13.2
None on Exploit-DB, Metasploit or GitHub

Summary

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • auth0 auth0.js

    From 8.0.0 · fixed in 9.12.3

  • auth0-jsnpm

    From 8.0.0 · fixed in 9.13.2

References 2

GitHub · auth0/auth0.js