Skip to main content
← All vulnerabilities
CVE-2020-5220GHSA-PRG5-HG25-8GRQGHSA-8VP7-J5CJ-VVM2

Ability to expose data in Sylius by using an unintended serialisation group

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.3.13, 1.4.6, 1.5.1, 1.6.3, 1.3.16, and 5 more
None on Exploit-DB, Metasploit or GitHub

Summary

Sylius ResourceBundle accepts and uses any serialisation groups to be passed via a HTTP header. This might lead to data exposure by using an unintended serialisation group - for example it could make Shop API use a more permissive group from Admin API. Anyone exposing an API with ResourceBundle's controller is affected. The vulnerable versions are: <1.3 || >=1.3.0 <=1.3.12 || >=1.4.0 <=1.4.5 || >=1.5.0 <=1.5.0 || >=1.6.0 <=1.6.2. The patch is provided for Sylius ResourceBundle 1.3.13, 1.4.6, 1.5.1 and 1.6.3, but not for any versions below 1.3.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Sylius SyliusResourceBundle

    fixed in 1.3.13; From 1.4.0 · fixed in 1.4.6; From 1.5.0 · fixed in 1.5.1; From 1.6.0 · fixed in 1.6.3

  • sylius/syliusPackagist

    fixed in 1.3.16

  • sylius/syliusPackagist

    From 1.4.0 · fixed in 1.4.12

  • sylius/syliusPackagist

    From 1.5 · fixed in 1.5.9

  • sylius/syliusPackagist

    From 1.6.0 · fixed in 1.6.5

  • sylius/resource-bundlePackagist

    From 1.4.0 · fixed in 1.4.6

  • sylius/resource-bundlePackagist

    From 1.5.0 · fixed in 1.5.1

  • sylius/resource-bundlePackagist

    From 1.6.0 · fixed in 1.6.3

  • sylius/syliusPackagist

    fixed in 1.3.12

  • sylius/syliusPackagist

    From 1.4.0 · fixed in 1.4.4

  • sylius/resource-bundlePackagist

    From 1.0.0 · fixed in 1.3.13

References 2

GitHub · Sylius/SyliusResourceBundle

GitHub · FriendsOfPHP/security-advisories