CVE-2020-5216GHSA-W978-RMPF-QMWG
Limited header injection when using dynamic overrides with user input in RubyGems secure_headers
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.9.0, 5.2.0, 6.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.
Timeline
- CVE published
- Record last updated
Affected versions
- Twitter secure_headers
fixed in 3.9.0; From 5.0.0 · fixed in 5.2.0; From 6.0.0 · fixed in 6.3.0
- secure_headersRubyGems
From 6.0.0 · fixed in 6.3.0
- secure_headersRubyGems
From 5.0.0 · fixed in 5.2.0
- secure_headersRubyGems
fixed in 3.9.0