XSS in Dijit Editor's LinkDialog plugin
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.
Timeline
- CVE published
- Record last updated
Affected versions
- Dojo dijit
fixed in 1.11.11; From 1.12.0 · fixed in 1.12.9; From 1.13.0 · fixed in 1.13.8; From 1.14.0 · fixed in 1.14.7; From 1.15.0 · fixed in 1.15.4; From 1.16.0 · fixed in 1.16.3
- dijitnpm
fixed in 1.11.11
- dijitnpm
From 1.12.0 · fixed in 1.12.9
- dijitnpm
From 1.13.0 · fixed in 1.13.8
- dijitnpm
From 1.14.0 · fixed in 1.14.7
- dijitnpm
From 1.15.0 · fixed in 1.15.4
- dijitnpm
From 1.16.0 · fixed in 1.16.3